aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-02-01 16:11:53 -0800
committersadbeast <sadbeast@sadbeast.com>2025-01-11 17:58:17 -0800
commit6637ef371082d88c45952f1094df709ea988b7b4 (patch)
tree99a8de3d0402a0dc7d6b972a6c47258871cfab57 /flake.nix
downloadanxiety-main.tar.gz
anxiety-main.tar.bz2
initial mistakeHEADmain
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..ac88504
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,26 @@
+{
+ description = "anxiety";
+
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = {
+ nixpkgs,
+ flake-utils,
+ ...
+ }:
+ flake-utils.lib.eachDefaultSystem (
+ system: let
+ pkgs = nixpkgs.legacyPackages.${system};
+
+ nativeBuildInputs = with pkgs; [
+ gnumake
+ ];
+ buildInputs = with pkgs; [];
+ in {
+ devShells.default = pkgs.mkShell {inherit nativeBuildInputs buildInputs;};
+ }
+ );
+}