aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..ac88504
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,26 @@
+{
+ description = "anxiety";
+
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = {
+ nixpkgs,
+ flake-utils,
+ ...
+ }:
+ flake-utils.lib.eachDefaultSystem (
+ system: let
+ pkgs = nixpkgs.legacyPackages.${system};
+
+ nativeBuildInputs = with pkgs; [
+ gnumake
+ ];
+ buildInputs = with pkgs; [];
+ in {
+ devShells.default = pkgs.mkShell {inherit nativeBuildInputs buildInputs;};
+ }
+ );
+}