aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2024-10-05 16:44:14 -0700
commit09513b5c4e4babfaefdd06c592ef34c0908dc572 (patch)
tree5a9af6ef0407346c223334e295adc8012654f112 /flake.nix
downloadnix-config-main.tar.gz
nix-config-main.tar.bz2
oh god what have i doneHEADmain
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix137
1 files changed, 137 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..e118890
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,137 @@
+{
+ description = "my nix config";
+
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+ # You can access packages and modules from different nixpkgs revs
+ # at the same time. Here's a working example:
+ nixpkgs-stable.url = "github:nixos/nixpkgs/nixos-24.05";
+ # Also see the 'stable-packages' overlay at 'overlays/default.nix'.
+
+ # Third party programs, packaged with nix
+ firefox-addons = {
+ url = "gitlab:rycee/nur-expressions?dir=pkgs/firefox-addons";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+
+ home-manager = {
+ url = "github:nix-community/home-manager";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+
+ impermanence.url = "github:nix-community/impermanence";
+
+ sops-nix.url = "github:Mic92/sops-nix";
+
+ systems.url = "github:nix-systems/default-linux";
+ };
+
+ outputs = {
+ self,
+ nixpkgs,
+ home-manager,
+ systems,
+ ...
+ } @ inputs: let
+ inherit (self) outputs;
+ lib = nixpkgs.lib // home-manager.lib;
+ forEachSystem = f: lib.genAttrs (import systems) (system: f pkgsFor.${system});
+ pkgsFor = lib.genAttrs (import systems) (
+ system:
+ import nixpkgs {
+ inherit system;
+ config.allowUnfree = true;
+ }
+ );
+ in {
+ inherit lib;
+ # Your custom packages
+ # Accessible through 'nix build', 'nix shell', etc
+ packages = forEachSystem (pkgs: import ./pkgs {inherit pkgs;});
+
+ # Formatter for your nix files, available through 'nix fmt'
+ # Other options beside 'alejandra' include 'nixpkgs-fmt'
+ formatter = forEachSystem (pkgs: pkgs.alejandra);
+
+ # Your custom packages and modifications, exported as overlays
+ overlays = import ./overlays {inherit inputs outputs;};
+ # Reusable nixos modules you might want to export
+ # These are usually stuff you would upstream into nixpkgs
+ nixosModules = import ./modules/nixos;
+ # Reusable home-manager modules you might want to export
+ # These are usually stuff you would upstream into home-manager
+ homeManagerModules = import ./modules/home-manager;
+
+ devShells = forEachSystem (pkgs: {
+ shell = pkgs.mkShell {
+ name = "nix-config";
+ nativeBuildInputs = [pkgs.sops];
+ };
+ });
+
+ # NixOS configuration entrypoint
+ # Available through 'nixos-rebuild --flake .#your-hostname'
+ nixosConfigurations = {
+ wopr = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs outputs;};
+ modules = [
+ ./hosts/wopr
+ ];
+ };
+ joshua = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs outputs;};
+ modules = [
+ ./hosts/joshua
+ ];
+ };
+ norad = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs outputs;};
+ modules = [
+ ./hosts/norad
+ ];
+ };
+ work = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs outputs;};
+ modules = [
+ ./hosts/work
+ ];
+ };
+ };
+
+ # Standalone home-manager configuration entrypoint
+ # Available through 'home-manager --flake .#your-username@your-hostname'
+ homeConfigurations = {
+ "sadbeast@wopr" = home-manager.lib.homeManagerConfiguration {
+ pkgs = pkgsFor.x86_64-linux;
+ extraSpecialArgs = {inherit inputs outputs;};
+ modules = [
+ ./home/sadbeast/wopr.nix
+ ];
+ };
+
+ "sadbeast@joshua" = home-manager.lib.homeManagerConfiguration {
+ pkgs = pkgsFor.x86_64-linux;
+ extraSpecialArgs = {inherit inputs outputs;};
+ modules = [
+ ./home/sadbeast/joshua.nix
+ ];
+ };
+
+ "sadbeast@norad" = home-manager.lib.homeManagerConfiguration {
+ pkgs = pkgsFor.x86_64-linux;
+ extraSpecialArgs = {inherit inputs outputs;};
+ modules = [
+ ./home/sadbeast/norad.nix
+ ];
+ };
+
+ "sadbeast@work" = home-manager.lib.homeManagerConfiguration {
+ pkgs = pkgsFor.x86_64-linux;
+ extraSpecialArgs = {inherit inputs outputs;};
+ modules = [
+ ./home/sadbeast/work.nix
+ ];
+ };
+ };
+ };
+}