aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/features/desktop/waybar.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2024-10-05 16:44:14 -0700
commit09513b5c4e4babfaefdd06c592ef34c0908dc572 (patch)
tree5a9af6ef0407346c223334e295adc8012654f112 /home/sadbeast/features/desktop/waybar.nix
downloadnix-config-09513b5c4e4babfaefdd06c592ef34c0908dc572.tar.gz
nix-config-09513b5c4e4babfaefdd06c592ef34c0908dc572.tar.bz2
oh god what have i doneHEADmain
Diffstat (limited to 'home/sadbeast/features/desktop/waybar.nix')
-rw-r--r--home/sadbeast/features/desktop/waybar.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/home/sadbeast/features/desktop/waybar.nix b/home/sadbeast/features/desktop/waybar.nix
new file mode 100644
index 0000000..02410b4
--- /dev/null
+++ b/home/sadbeast/features/desktop/waybar.nix
@@ -0,0 +1,57 @@
+{
+ programs.waybar = {
+ enable = true;
+ systemd.enable = true;
+
+ settings = {
+ mainBar = {
+ layer = "bottom";
+ position = "top";
+ height = 20;
+
+ modules-left = ["sway/workspaces" "sway/mode" "sway/window"];
+ modules-right = ["tray" "battery" "clock"];
+
+ "sway/workspaces" = {
+ format = "{name}";
+ disable-scroll = true;
+ };
+
+ "sway/mode" = {
+ format = " {}";
+ };
+
+ "sway/window" = {
+ max-length = 80;
+ tooltip = false;
+ };
+
+ clock = {
+ format = "{:%a %d %I:%M}";
+ tooltip = false;
+ };
+
+ battery = {
+ format = "{capacity}% {icon}";
+ format-alt = "{time} {icon}";
+ format-icons = ["" "" "" "" ""];
+ format-charging = "{capacity}% ";
+ interval = 30;
+
+ states = {
+ warning = 25;
+ critical = 10;
+ };
+
+ tooltip = false;
+ };
+
+ tray = {
+ icon-size = 18;
+ };
+ };
+ };
+
+ style = ./waybar.css;
+ };
+}