aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/features/games.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2025-01-11 12:20:20 -0800
commit8c12d7db633cc421cd96690d077461cf45195334 (patch)
treec3112acb5cd045ceeb2ada81a281a5991b4c501d /home/sadbeast/features/games.nix
downloadnix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.gz
nix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.bz2
oh no what have i doneHEADmain
Diffstat (limited to 'home/sadbeast/features/games.nix')
-rw-r--r--home/sadbeast/features/games.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/home/sadbeast/features/games.nix b/home/sadbeast/features/games.nix
new file mode 100644
index 0000000..e90a323
--- /dev/null
+++ b/home/sadbeast/features/games.nix
@@ -0,0 +1,26 @@
+{
+ pkgs,
+ config,
+ ...
+}: {
+ home = {
+ packages = with pkgs; [
+ discord
+ ez80asm
+ fab-agon-emulator
+ fceux
+ (retroarch.withCores (cores:
+ with cores; [
+ mesen
+ gambatte
+ ]))
+ ];
+ };
+
+ # programs.steam = {
+ # enable = true;
+ # remotePlay.openFirewall = true; # Open ports in the firewall for Steam Remote Play
+ # dedicatedServer.openFirewall = true; # Open ports in the firewall for Source Dedicated Server
+ # localNetworkGameTransfers.openFirewall = true; # Open ports in the firewall for Steam Local Network Game Transfers
+ # };
+}