aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/features/pass.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2024-10-05 16:44:14 -0700
commit09513b5c4e4babfaefdd06c592ef34c0908dc572 (patch)
tree5a9af6ef0407346c223334e295adc8012654f112 /home/sadbeast/features/pass.nix
downloadnix-config-09513b5c4e4babfaefdd06c592ef34c0908dc572.tar.gz
nix-config-09513b5c4e4babfaefdd06c592ef34c0908dc572.tar.bz2
oh god what have i doneHEADmain
Diffstat (limited to 'home/sadbeast/features/pass.nix')
-rw-r--r--home/sadbeast/features/pass.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/home/sadbeast/features/pass.nix b/home/sadbeast/features/pass.nix
new file mode 100644
index 0000000..0a64f41
--- /dev/null
+++ b/home/sadbeast/features/pass.nix
@@ -0,0 +1,17 @@
+{
+ pkgs,
+ config,
+ ...
+}: {
+ programs.password-store = {
+ enable = true;
+ settings = {
+ PASSWORD_STORE_DIR = "$HOME/.password-store";
+ };
+ package = pkgs.pass.withExtensions (p: [p.pass-otp]);
+ };
+
+ # home.persistence = {
+ # "/persistent${config.home.homeDirectory}".directories = [".password-store"];
+ # };
+}