aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/features/ssh.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2025-01-11 12:20:20 -0800
commit8c12d7db633cc421cd96690d077461cf45195334 (patch)
treec3112acb5cd045ceeb2ada81a281a5991b4c501d /home/sadbeast/features/ssh.nix
downloadnix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.gz
nix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.bz2
oh no what have i doneHEADmain
Diffstat (limited to 'home/sadbeast/features/ssh.nix')
-rw-r--r--home/sadbeast/features/ssh.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/home/sadbeast/features/ssh.nix b/home/sadbeast/features/ssh.nix
new file mode 100644
index 0000000..d6ee92c
--- /dev/null
+++ b/home/sadbeast/features/ssh.nix
@@ -0,0 +1,32 @@
+{
+ programs.ssh = {
+ enable = true;
+
+ matchBlocks = {
+ "falken" = {
+ hostname = "sadbeast.com";
+ port = 6973;
+ };
+
+ "crystalpalace" = {
+ hostname = "192.168.0.2";
+ port = 6973;
+ };
+
+ "joshua" = {
+ hostname = "192.168.0.3";
+ };
+
+ "teamdraft" = {
+ hostname = "teamdraft.net";
+ port = 6973;
+ };
+
+ "work" = {
+ hostname = "192.168.0.26";
+ forwardX11 = true;
+ forwardX11Trusted = true;
+ };
+ };
+ };
+}