aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/joshua.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2025-01-11 12:20:20 -0800
commit8c12d7db633cc421cd96690d077461cf45195334 (patch)
treec3112acb5cd045ceeb2ada81a281a5991b4c501d /home/sadbeast/joshua.nix
downloadnix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.gz
nix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.bz2
oh no what have i doneHEADmain
Diffstat (limited to 'home/sadbeast/joshua.nix')
-rw-r--r--home/sadbeast/joshua.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/home/sadbeast/joshua.nix b/home/sadbeast/joshua.nix
new file mode 100644
index 0000000..f41f96d
--- /dev/null
+++ b/home/sadbeast/joshua.nix
@@ -0,0 +1,27 @@
+{
+ pkgs,
+ config,
+ lib,
+ ...
+}: {
+ imports = [
+ ./global
+ ./features/desktop
+ ./features/games.nix
+ ];
+
+ # ---------- ---------
+ # | HDMI-A-1 | | DVI-D-1 |
+ # ---------- ---------
+
+ wayland.windowManager.sway.config.output = {
+ HDMI-A-1 = {
+ resolution = "1920x1080";
+ position = "0,0";
+ };
+ DVI-D-1 = {
+ resolution = "1920x1080";
+ position = "1920,0";
+ };
+ };
+}