aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/work.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2024-10-05 16:44:14 -0700
commit09513b5c4e4babfaefdd06c592ef34c0908dc572 (patch)
tree5a9af6ef0407346c223334e295adc8012654f112 /home/sadbeast/work.nix
downloadnix-config-09513b5c4e4babfaefdd06c592ef34c0908dc572.tar.gz
nix-config-09513b5c4e4babfaefdd06c592ef34c0908dc572.tar.bz2
oh god what have i doneHEADmain
Diffstat (limited to 'home/sadbeast/work.nix')
-rw-r--r--home/sadbeast/work.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/home/sadbeast/work.nix b/home/sadbeast/work.nix
new file mode 100644
index 0000000..5d253e8
--- /dev/null
+++ b/home/sadbeast/work.nix
@@ -0,0 +1,64 @@
+{
+ pkgs,
+ config,
+ lib,
+ ...
+}: {
+ imports = [
+ ./global
+ ./features/desktop
+ ];
+
+ home = {
+ sessionVariables = {
+ BUNDLE_PATH = "vendor/bundle";
+ };
+
+ packages = with pkgs; [
+ aws-sam-cli
+ awscli2
+ gcc
+ google-chrome
+ ruby
+ nodejs
+ slack
+ ruby-lsp
+ ssm-session-manager-plugin
+ ];
+ };
+
+ programs = {
+ git = {
+ userName = "Kent Smith";
+ userEmail = "kent.smith@andros.co";
+
+ extraConfig = {
+ core.sshCommand = "ssh -i ~/.ssh/id_rsa -o IdentitiesOnly=yes";
+ };
+ };
+
+ obs-studio = {
+ enable = true;
+ plugins = with pkgs.obs-studio-plugins; [
+ wlrobs
+ obs-backgroundremoval
+ obs-pipewire-audio-capture
+ ];
+ };
+ };
+
+ wayland.windowManager.sway.config.output = {
+ eDP-1 = {
+ resolution = "1920x1080";
+ position = "0,0";
+ };
+ HDMI-A-1 = {
+ resolution = "1920x1080";
+ position = "0,1080";
+ };
+ DP-1 = {
+ resolution = "1920x1080";
+ position = "1920,1080";
+ };
+ };
+}