aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/work.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2025-01-11 12:20:20 -0800
commit8c12d7db633cc421cd96690d077461cf45195334 (patch)
treec3112acb5cd045ceeb2ada81a281a5991b4c501d /home/sadbeast/work.nix
downloadnix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.gz
nix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.bz2
oh no what have i doneHEADmain
Diffstat (limited to 'home/sadbeast/work.nix')
-rw-r--r--home/sadbeast/work.nix94
1 files changed, 94 insertions, 0 deletions
diff --git a/home/sadbeast/work.nix b/home/sadbeast/work.nix
new file mode 100644
index 0000000..88bc307
--- /dev/null
+++ b/home/sadbeast/work.nix
@@ -0,0 +1,94 @@
+{
+ pkgs,
+ config,
+ lib,
+ ...
+}: {
+ imports = [
+ ./global
+ ./features/desktop
+ ];
+
+ home = {
+ packages = with pkgs; [
+ adrs
+ aws-sam-cli
+ awscli2
+ vscode
+ vscode-extensions.github.copilot-chat
+ gcc
+ glow
+ google-chrome
+ libreoffice
+ nodejs
+ ngrok
+ pop
+ pgcli
+ #ruby
+ #ruby-lsp
+ sshfs
+ slack
+ ssm-session-manager-plugin
+ tmate
+ virt-manager
+ zoom
+ ];
+
+ sessionVariables = {
+ CODEARTIFACT_AUTH_CMD = "aws codeartifact get-authorization-token --domain andros --domain-owner 111491220182 --region us-east-2 --query authorizationToken --output text";
+ };
+ };
+
+ programs = {
+ git = {
+ userName = "Kent Smith";
+ userEmail = "kent.smith@andros.co";
+
+ extraConfig = {
+ core.sshCommand = "ssh -i ~/.ssh/id_rsa -o IdentitiesOnly=yes";
+ };
+ };
+
+ obs-studio = {
+ enable = true;
+ plugins = with pkgs.obs-studio-plugins; [
+ wlrobs
+ obs-backgroundremoval
+ obs-pipewire-audio-capture
+ ];
+ };
+
+ qutebrowser = {
+ settings.content.blocking.whitelist = [
+ "app.bugsnag.com"
+ ];
+ };
+ };
+
+ xdg.mimeApps.defaultApplications = {
+ "text/html" = "google-chrome.desktop";
+ "x-scheme-handler/http" = "google-chrome.desktop";
+ "x-scheme-handler/https" = "google-chrome.desktop";
+ "x-scheme-handler/about" = "google-chrome.desktop";
+ "x-scheme-handler/unknown" = "google-chrome.desktop";
+ };
+
+ wayland.windowManager.sway.config.output = {
+ eDP-1 = {disable = "disable";};
+ # eDP-1 = {
+ # disable = true;
+ # # resolution = "1920x1080";
+ # # position = "0,0";
+ # };
+ HDMI-A-1 = {
+ resolution = "1920x1080";
+ # position = "0,1080";
+ position = "0,0";
+ };
+ DP-1 = {
+ resolution = "1920x1080";
+ # position = "1920,1080";
+ position = "1920,0";
+ };
+ };
+}