diff options
author | sadbeast <sadbeast@sadbeast.com> | 2024-05-30 00:47:47 +0000 |
---|---|---|
committer | sadbeast <sadbeast@sadbeast.com> | 2025-01-11 12:20:20 -0800 |
commit | 8c12d7db633cc421cd96690d077461cf45195334 (patch) | |
tree | c3112acb5cd045ceeb2ada81a281a5991b4c501d /iso.nix | |
download | nix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.gz nix-config-8c12d7db633cc421cd96690d077461cf45195334.tar.bz2 |
Diffstat (limited to 'iso.nix')
-rw-r--r-- | iso.nix | 24 |
1 files changed, 24 insertions, 0 deletions
@@ -0,0 +1,24 @@ +# Build: +# nix-build '<nixpkgs/nixos>' -A config.system.build.isoImage -I nixos-config=iso.nix +# +# Test: +# $ nix-shell -p qemu --run "qemu-system-x86_64 -enable-kvm -m 256 -cdrom result/iso/nixos-*.iso" +{ + config, + pkgs, + ... +}: { + imports = [ + <nixpkgs/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix> + + # Provide an initial copy of the NixOS channel so that the user + # doesn't need to run "nix-channel --update" first. + <nixpkgs/nixos/modules/installer/cd-dvd/channel.nix> + ]; + environment.systemPackages = [pkgs.git pkgs.sops]; + + # The build process is slow because of compression - use a faster compressor + isoImage.squashfsCompression = "gzip -Xcompression-level 1"; + + console.keyMap = "emacs2"; +} |