aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/features/pass.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/sadbeast/features/pass.nix')
-rw-r--r--home/sadbeast/features/pass.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/home/sadbeast/features/pass.nix b/home/sadbeast/features/pass.nix
new file mode 100644
index 0000000..0a64f41
--- /dev/null
+++ b/home/sadbeast/features/pass.nix
@@ -0,0 +1,17 @@
+{
+ pkgs,
+ config,
+ ...
+}: {
+ programs.password-store = {
+ enable = true;
+ settings = {
+ PASSWORD_STORE_DIR = "$HOME/.password-store";
+ };
+ package = pkgs.pass.withExtensions (p: [p.pass-otp]);
+ };
+
+ # home.persistence = {
+ # "/persistent${config.home.homeDirectory}".directories = [".password-store"];
+ # };
+}