aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/common/global/sops.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/common/global/sops.nix')
-rw-r--r--hosts/common/global/sops.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hosts/common/global/sops.nix b/hosts/common/global/sops.nix
new file mode 100644
index 0000000..9d1d42b
--- /dev/null
+++ b/hosts/common/global/sops.nix
@@ -0,0 +1,17 @@
+{
+ inputs,
+ lib,
+ config,
+ ...
+}: {
+ imports = [inputs.sops-nix.nixosModules.sops];
+
+ sops = {
+ age = {
+ #keyFile = "/persistent/var/lib/sops-nix/keys.txt";
+ keyFile = "/var/lib/sops-nix/keys.txt";
+ sshKeyPaths = [];
+ };
+ gnupg.sshKeyPaths = [];
+ };
+}