aboutsummaryrefslogtreecommitdiffstats
path: root/hosts/norad/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/norad/default.nix')
-rw-r--r--hosts/norad/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/hosts/norad/default.nix b/hosts/norad/default.nix
new file mode 100644
index 0000000..c1126b2
--- /dev/null
+++ b/hosts/norad/default.nix
@@ -0,0 +1,26 @@
+{
+ imports = [
+ ./hardware-configuration.nix
+
+ ../common/global
+ ../common/optional/wireless.nix
+ ];
+
+ # Use the systemd-boot EFI boot loader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.hostName = "norad";
+
+ # Slows down write operations considerably
+ nix.settings.auto-optimise-store = false;
+
+ services = {
+ logind.extraConfig = ''
+ HandleLidSwitchExternalPower=ignore
+ '';
+ };
+
+ # https://nixos.wiki/wiki/FAQ/When_do_I_update_stateVersion
+ system.stateVersion = "24.05";
+}