aboutsummaryrefslogtreecommitdiffstats
path: root/iso.nix
diff options
context:
space:
mode:
Diffstat (limited to 'iso.nix')
-rw-r--r--iso.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/iso.nix b/iso.nix
new file mode 100644
index 0000000..cfd9260
--- /dev/null
+++ b/iso.nix
@@ -0,0 +1,24 @@
+# Build:
+# nix-build '<nixpkgs/nixos>' -A config.system.build.isoImage -I nixos-config=iso.nix
+#
+# Test:
+# $ nix-shell -p qemu --run "qemu-system-x86_64 -enable-kvm -m 256 -cdrom result/iso/nixos-*.iso"
+{
+ config,
+ pkgs,
+ ...
+}: {
+ imports = [
+ <nixpkgs/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix>
+
+ # Provide an initial copy of the NixOS channel so that the user
+ # doesn't need to run "nix-channel --update" first.
+ <nixpkgs/nixos/modules/installer/cd-dvd/channel.nix>
+ ];
+ environment.systemPackages = [pkgs.git pkgs.sops];
+
+ # The build process is slow because of compression - use a faster compressor
+ isoImage.squashfsCompression = "gzip -Xcompression-level 1";
+
+ console.keyMap = "emacs2";
+}