aboutsummaryrefslogtreecommitdiffstats
path: root/home/sadbeast/joshua.nix
diff options
context:
space:
mode:
authorsadbeast <sadbeast@sadbeast.com>2024-05-30 00:47:47 +0000
committersadbeast <sadbeast@sadbeast.com>2024-10-05 16:44:14 -0700
commit09513b5c4e4babfaefdd06c592ef34c0908dc572 (patch)
tree5a9af6ef0407346c223334e295adc8012654f112 /home/sadbeast/joshua.nix
downloadnix-config-09513b5c4e4babfaefdd06c592ef34c0908dc572.tar.gz
nix-config-09513b5c4e4babfaefdd06c592ef34c0908dc572.tar.bz2
oh god what have i doneHEADmain
Diffstat (limited to 'home/sadbeast/joshua.nix')
-rw-r--r--home/sadbeast/joshua.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/home/sadbeast/joshua.nix b/home/sadbeast/joshua.nix
new file mode 100644
index 0000000..44c3a47
--- /dev/null
+++ b/home/sadbeast/joshua.nix
@@ -0,0 +1,26 @@
+{
+ pkgs,
+ config,
+ lib,
+ ...
+}: {
+ imports = [
+ ./global
+ ./features/desktop
+ ];
+
+ # ---------- ---------
+ # | HDMI-A-1 | | DVI-D-1 |
+ # ---------- ---------
+
+ wayland.windowManager.sway.config.output = {
+ HDMI-A-1 = {
+ resolution = "1920x1080";
+ position = "0,0";
+ };
+ DVI-D-1 = {
+ resolution = "1920x1080";
+ position = "1920,0";
+ };
+ };
+}